"Your network is behind a port-symmetric nat"

I need help. I’ve done the double shoulders thing, I’ve made a static ip for my xbox one, I’ve opened the ports necessary for the Xbox one, yet I still have a strict nat. I use a Vivint router which doesn’t show up on the port forward website. UPNP is enabled. I don’t think I would like to use DMZ. Someone PLEASE help me.

I think your best bet would be to contact your ISP, they’ll have the specifics that you need, hopefully. Also, a friend of mine had the same issue until he went Ethernet instead of wireless. You could try that if you haven’t already.