Update Nov 3 not starting

The game wants an update, but it doesn’t start. Progress stays at 0 percent. I’ve tried pausing it but the status stays on "updating… " This is about two hours now.
After a history of update and licence problems, and a factory reset that solved them, I’m so annoyed right now. Love the game but wtf why release an update when there are obvious and acknowledged issues with them.
Oh, news flash: error code 0x8027025a.
Well that explains it…

Exact same issue here. I can’t run anything else on my Xbox due to error 0x8027025a (took too long to start).

I was one of the lucky few who never had issues updating HW2 before.

UPDATE: the download finally paused 30 minutes after I tried to pause it. Restarted the download and everything seems fine for now. I did not reboot my Xbox at all during the process.

Update:
My Xbox wouldn’t respond at all so I turned it off completely. After reboot the update started, but now 42gb instead of 11gb. The game works again so that is good.
This is the exact behavior (full install after reboot) as before so I’m keeping my fingers crossed I don’t have a corrupted installation again.