Two of my achievements will not unlock

Both achievements “Clever Girl” and “Pigs Can Fly” in Halo 4 will not unlock for me. I have no idea why they won’t unlock. I unlocked “I Thrust at Thee” in a game, then switched my loadout from the thruster pack to the active camo. After I got 5 kills while active camo was being used, the achievement never popped. So I tried to unlock it again and again. I did the same for killing three people while they are using a jetpack. I even continued to try to unlock them on all three different maps: Landfall, Monolith, and Skyline. The achievements refused to unlock. So I went into my storage on my Xbox 360 and cleared the cache as well as deleting each DLC (just to be safe) and the update for Halo 4. After re-downloading the update and the DLC, I attempted to get the achievement again. This still did not work. So then I proceeded to go through every single item on my hard drive to make sure everything was not corrupted. Not a single item was, as I went through every single one. I then went ahead and deleted absolutely everything from Halo 4, cleared the cache, the content cache, and the transfer cache. I also deleted my profile off of the system. After re-downloading all of these items back onto my Xbox, I went for the achievement again. It still did not unlock. After this I was playing and I got the “ODST” achievement related to the Crimson Map Pack as well as the “Dedicated to Crimson” achievement, so obviously there’s just something wrong with the two specific achievements I am not unlocking. My roommate and I were also playing at the same time and he got both of these achievements to unlock in the same game that I originally attempted to unlock them, and both of his popped up with no problem at all. I called Microsoft several times to attempt to get solutions from them, and everything I had already done was what they ended up suggesting. I WOULD get in contact with 343 Industries’s customer service, but they don’t have any. Which is ridiculous. If someone is having technical problems with a game that YOU made, YOU should resolve it, as opposed to making someone who payed for the game you made go onto some forum and post their problem so that it can sit there and have no help ever come. How is that a good business model? Other users shouldn’t be the ones to help other users. The company should. But if anyone does have any solutions of similar problems, please post here. This seems unlikely though considering how ridiculous my particular issue is. Thank you.

-Guard226Duck

I’m missing out on the ‘Ashes to Ashes’ achievement, and I did pretty much everything that Guard226Duck did. I’m hoping they release a patch soon.

And now Ashes to Ashes won’t unlock for me either. These three achievements are the only ones I’m missing in the game…

I have tried to unlock the achievements of the majestic dlc
Especially achieving: bird of prey, smart girl and everything is possible,
but when I do what you ask is not desbloquen and have already made ​​several times and would not leave.