Trying to update halo waypoint on my 360

I’ve recently come back to Halo with news of Halo Infinite finally teaching me. Going back through videos I noticed that there are so many things I never did when I first played and am now going back through and getting achievements and replaying games on a higher difficulty. I saw that halo waypoint on the 360 would allow me to get some in-game items for Halo Reach and was ecstatic to finally get items that I’d never achieved. Upon opening halo waypoint on my 360 a message was displayed asking me to update the application. The options were “Ok” or “Exit”. I clicked “Ok” and my screen froze to where if I held the home button down nothing would happen. I then shut down my Xbox and tried again, this time pressing the “Exit” option. This ended up closing the application. I then tried a third time by clicking “Ok” and letting it sit over night. I woke up to find no change on the screen. What can I do to update the halo waypoint app on my 360?

Edit: Was able time get into it yesterday