Technical Difficulties

Over the past month, I’ve replaced my router, simplified my network, and installed wired lines directly to my Xbox. I’ve set my router to expose my Xbox directly to the internet via DMZ, which means my NAT is open and I have the best possible connection for my area (I have DSL). I say all this to forego the standard “Open your NAT” and “Port Forward” advice, as I’ve already taken care of these things (I am an IT graduate…).

What I don’t understand, however, is why I can only play one or two games at a time in Matchmaking before having to shut down my Xbox, powercycle my networking equipment, and then wait a couple minutes before booting up Reach again just to have access to challenges and my service record. Essentially, I will randomly start seeing issues crop up (listed in the next section of this post: “Symptoms”) and unless I powercycle my router they don’t seem to fix themselves.

As far as I can tell, I’ve only run into this issue when playing Halo: Reach and not while playing other games, though once it has occurred it affects my other games and services until I reset my equipment. Is there something else I can be doing that I’m just overlooking, or is there an issue on your end, 343i?

SYMPTOMS

  • In the lobby, my nameplate color goes to the default black/steel color, and my rank shows recruit. If I go to the armory, my correct rank, color, and armor configuration is still there.
  • When I press start, “Challenges” are greyed out and I cannot access them or make progress on them.
  • I will typically get the “Halo Reach servers are unavailable” message when I try to go into matchmaking.
  • I will also be unable to connect to the Waypoint servers if I try to go to Waypoint, and other services also suffer (Netflix fails, for example) but I can still be in an Xbox LIVE party with friends and send and receive messages.

RELATED THREADS

I’ve found a number of other threads describing this same issue. As I find more I will add them to the list. While a number of them apparently have something to do with an ISP in New Zealand, the problem is not limited there. I personally am in the US and have had this problem for quite some time. The fact there are so many of these threads should be an indication of how big this problem is.

We finally have some progress to report! Assuming this is legit, Joriarty seems to have found a reason for the issue.

> I’ve been in contact with Xbox Support for weeks now… three phone calls now. Their techs were supposed to call me back (and didn’t) with a solution, so I called back today and now they want me to directly connect my Xbox to my modem/router, as I currently run it through a second, wireless, router (which would be a much bigger nuisance than it sounds).
>
> facepalm. I had already spent half an hour arguing that wasn’t going to fix anything, along with anything else on their arbitrary troubleshooting checklist.
>
> Since then, Slingshot have directly confirmed to me that the issue lies with our IP addresses. Only customers on Slingshot’s unlimited internet plan have the problem. You can solve it by either changing plan, or getting a $10/month static IP that starts with something other than 101. Our IP addresses on the unlimited plan start with 101, which appears to be the issue, as customers on other plans with different plans are unaffected.
>
> I have relayed this to Xbox support, and I should now get a call back in 3-5 business days. All we need is for the Halo: Reach servers to be configured so that they can “see” IP addresses that begin with 101.
>
> That can’t be too hard to fix, if I can somehow get past the Xbox call centre folks and on to whoever administers the servers (343? Who have no contact details). It’s frustrating how obtuse the support process is, but fingers crossed we’ll get something soon. If there’s still no progress, I’ll just ask for a refund on the Anniversary map pack which I bought and then found out I couldn’t actually play.

UPDATE: My issue has been solved and appears to have been a faulty router (despite being brand new). However, as there are plenty of people who are still having this problem and it seems apparent that there IS a server-side problem, this thread will remain open for them.

Sounds like a problem on their end. I typically have the same problems with people’s service record not coming up, getting the ‘Reach matchmaking server is down’ message, slow loading time on challenge progression, etc. When it happens to me, it is not as severe though. I just back out into the main menu and go back into what I was doing and the problem usually fixes itself. Although I doubt this will work for you judging by the severity of your problems. For extra help to get this thread recognized by 343, I would copy and paste it into the feedback forum so that they may hopefully fix it.

Thanks, I’ll copy/paste this then. I wasn’t sure where I should put it, and figured since it only happens with Reach this would be appropriate.

have you considered restarting your router and opening your NAT??

totally kidding, don’t hit me. :slight_smile:

anyways, i’ve had that happen and i do think it’s something on their end, nothing you’ve done wrong.

eye twitches

:stuck_out_tongue:

Was it eventually fixed for you, snickerdoodle?

lol, sorry, i couldn’t resist. :slight_smile:

ehhh it comes and goes. i haven’t really found a magic fix for it.

if i’m with a group and it’s spazzing and not letting us play MM because the servers are unavailable, we’ll go play through a quick custom game or something and then try again. sometimes we get into MM with the wonky ranks (and then joke about being paired up with other recruits when really? our “recruit” is really a Reclaimer or something). it’s touch and go…i’ve never had to power down everything though.

I know that powercycling will fix it, but it’s never fixed itself after sitting for an hour or two, and it hasn’t fixed itself after running through campaign missions. Not even sure if it will let me party up with anyone to play a custom but I can try that too.

ADDITIONAL INFO:

I’m now convinced that it’s a server issue. I just tried looking at my waypoint career information on the website and got this error:

Service Error

Sorry, we encountered a problem while processing your request.
System.ServiceModel.CommunicationException
Internal Server Error

Server stack trace:
at System.ServiceModel.Dispatcher.WebFaultClientMessageInspector.AfterReceiveReply(Message& reply, Object correlationState)
at System.ServiceModel.Dispatcher.ImmutableClientRuntime.AfterReceiveReply(ProxyRpc& rpc)
at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)
at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object ins, Object outs, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object ins, Object outs)
at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at ICareerServiceXml.GetUserAchievements(UInt32 titleId)
at Waypoint.Client.Web.RestXmlCareerDataAccess.GetUserAchievements(IdentityToken userToken, UInt32 titleId) in c:\Builds\109\343 Section 3\Waypoint Web (Release)\Sources\SharedSource\Waypoint.Client\Waypoint.Client.Web\RestXmlCareerDataAccess.cs:line 106
at Waypoint.Client.Web.UI.Business.Services.CareerService.GetUserAchievements(IdentityToken userToken, UInt32 titleId) in c:\Builds\109\343 Section 3\Waypoint Web (Release)\Sources\Source\Waypoint.Client.Web.UI\Business\Services\CareerService.cs:line 246
at Waypoint.Client.Web.UI.Controllers.CareerController.<>c__DisplayClass1a.<GetPlayerAchievements>b__19() in c:\Builds\109\343 Section 3\Waypoint Web (Release)\Sources\Source\Waypoint.Client.Web.UI\Controllers\CareerController.cs:line 169
at Waypoint.Client.Web.UI.Controllers.BaseController.GetFromCacheOrLive[T](String id, Func1 servicemethod, Int32 seconds) in c:\Builds\109\343 Section 3\Waypoint Web (Release)\Sources\Source\Waypoint.Client.Web.UI\Controllers\BaseController.cs:line 728 at Waypoint.Client.Web.UI.Controllers.CareerController.GetPlayerAchievements(IdentityToken userToken, UInt32 gameTitleId) in c:\Builds\109\343 Section 3\Waypoint Web (Release)\Sources\Source\Waypoint.Client.Web.UI\Controllers\CareerController.cs:line 169 at Waypoint.Client.Web.UI.Controllers.CareerController.GetPlayerCardViewModel(Nullable1 gameId) in c:\Builds\109\343 Section 3\Waypoint Web (Release)\Sources\Source\Waypoint.Client.Web.UI\Controllers\CareerController.cs:line 1264
at Waypoint.Client.Web.UI.Controllers.CareerController.Overview(String id, String gamerTag) in c:\Builds\109\343 Section 3\Waypoint Web (Release)\Sources\Source\Waypoint.Client.Web.UI\Controllers\CareerController.cs:line 1189
at lambda_method(Closure , ControllerBase , Object )
at System.Web.Mvc.ReflectedActionDescriptor.Execute(ControllerContext controllerContext, IDictionary2 parameters) at System.Web.Mvc.ControllerActionInvoker.InvokeActionMethod(ControllerContext controllerContext, ActionDescriptor actionDescriptor, IDictionary2 parameters)
at System.Web.Mvc.ControllerActionInvoker.<>c__DisplayClass15.<InvokeActionMethodWithFilters>b__12()
at System.Web.Mvc.ControllerActionInvoker.InvokeActionMethodFilter(IActionFilter filter, ActionExecutingContext preContext, Func1 continuation) at System.Web.Mvc.ControllerActionInvoker.InvokeActionMethodWithFilters(ControllerContext controllerContext, IList1 filters, ActionDescriptor actionDescriptor, IDictionary`2 parameters)
at System.Web.Mvc.ControllerActionInvoker.InvokeAction(ControllerContext controllerContext, String actionName)

Sorry for the double-post, but it’s been quite awhile and still no response. Bumping for visibility.

I have issues like this every now and then as well. As far as I can figure out it’s an intermittent issue with their server but it usually fixes itself after a custom game or turning my box off/on. I’ve never had it happen to the extent it sounds like you have though, OP.

> I have issues like this every now and then as well. As far as I can figure out it’s an intermittent issue with their server but it usually fixes itself after a custom game or turning my box off/on. I’ve never had it happen to the extent it sounds like you have though, OP.

Yeah, it’s not intermittent for me. The system working correctly is intermittent for me. I just wish that I could at least get an ACKNOWLEDGEMENT that they’re aware of my situation. Bungie wasn’t perfect, but at least they were good about responding and letting us know they were aware of what was bothering us.

Saving Thread!

Having same issue, have made posts/threads as well.

Mark

GTs: LeitchNut, MAaReKay

That’s really frustrating. :frowning: I hope you find answers soon!

I had this problem for a short period of time after the anniversary playlist camout. But now its fine.

Things have been acting strangely for me too, but it’s pretty intermittent and not quite as severe. I’m pretty sure it’s on their end.

It’s unlikely, but depending on the age of your Xbox, it might be the network adapter itself, rather than your network.

Hopefully you can fix it!

I thought of that, but if it was the adapter then it wouldn’t just be Reach that suffered. I can play other games just fine, and I can use LIVE apps (like streaming music or video) with no problem. LIVE parties are also not an issue for me, it’s just connecting to Reach’s servers. Also, it’s one of the newer, slimmer models so I doubt it’s age.

That said, once that connection to Reach’s servers messes up, it starts to degrade other things. (sometimes I can’t use Netflix after losing connection to the Reach servers, for example) Like I said before, manually resetting the connection by powercycling my network equipment will “fix” the problem temporarily, but rarely lasts more than a game, and sometimes doesn’t work at all.

Thanks for all the support guys and gals!

I’ve noticed it has effected my other games, after playing a halo game online I can’t play my other games online. But if I play them without starting reach or CE I can play online. I hope it gets fixed soon.

Yeah, that’s the same thing that happens to me. Reach connection goes down, then I can’t stream netflix, or play multiplayer in other games. But if I don’t get on Reach then the other things work fine.

I don’t know how the hell I just did it, but I turned on uPnP and disabled the firewall and it’s working :D:D:D:D:D:D

Stopped working now.

Fudge, check the quote I added to the end of my OP. It seems somebody has found the reason and a workaround.