Spartan Assault on X1 not connecting to Co-op

Hello,

My friend and I have been trying for the last couple of days to play coop together on Spartan Assault on Xbox One and have been unable to do so. Every time that we connect to the same party and press Y (Invite to Party) we will only get the invite if we are not in the same party, we would then be invited into an Xbox One party but we would not be able to join the game. We also both tried to use the X (Find Player) button when we are both in a party and not in a party together and we are unable to connect to other players. Can somebody help with this? I spent $15 om this game hoping only to play Co-op and this is very frustrating.

Nevermind I figured it out. It was an Xbox issue. I had to “clear persistent storage” in the blu-ray section of the settings, three times. Then I had to remove my account from the Xbox One and after I went to settings, then change Alternate MAC address. Once I restarted my XBox and signed back in with my profile it worked.

Happy to hear you’re sorted, Dragon Spell. Here are a few tips you can try if you experience this again in the future. Make sure only one person is sending invites, not both.

  • Start a party together before entering the game. Once the party is created, enter multiplayer.
  • Enter co-op without a partner, and build the party from there.
    Happy Spartan Assault-ing!