Someone help with this dumb glitch

I’d like an employee more than anyone to read this, anyway

When i downloaded the noble/defiant map packs my anniversary map pack no longer worked, it says i don’t have it and i have tried much to fix it

-I tried redownloading all 3 map packs
-I don’t have Bungie pro

Someone please help

I’m no employee, however I can attempt to help.

Have you tried downloading Defiant and Noble first Then Anniversary 3rd?

If you have the Anniversary game download Defiant And Noble. Put in Anniversary and play on the maps via custom game or forge or something then redownload Anniversary Maps.

Which disk are you playing on? Maybe try playing playing it on the reach disk of your playing on CEA?

Halo defiant/noble, default map packs will not show on the Halo CEA disc, it will only appear on the Halo Reach disc. Not really why 343i did that but thats how it is at moment because the CEA is not the full edition of Reach since its CEA multiplayer only.

Also try clearng your cache.

I’m playing on my reach disk

> I’m playing on my reach disk

Apparently, there used to be some glitch where there was a cap on the amount of DLC you could have in Reach, and the pre-order armor permutations contributed to it. Basically, you have too much DLC. There’s a publicly-known fix that doesn’t require you to delete or lose anything, but I don’t know where it is.