Some Halo 4 related codes don't work on Waypoint

Hi everyone, I’m here to report this issue
I completed the Campaign of Halo 4 on LASO difficulty, then i tried to put the related code in Halo Waypoint. It didn’t work. You can check my stats to verify that i actually completed every mission of the campaign on LASO.
Although, i recently put in Halo Waypoint the Yanumas code (forgot to do it in the far 2014) and it worked.
Also, doing some search in the forum, i noticed that there are some players that have issues to put the Raider DSTT Helmet Code though they completed 1000+ War Games, and few other players that have the same LASO Code problem.
I think that is a bug involving statistic-related codes of Halo 4, because Halo Waypoint still tracks every stats of the game (at least Halo 4) and any other code works properly.
Can a technician verify and fix those LASO / Raider DSTT Helmet codes?
It means a lot for the little community of Halo 4, me and the few players involved.
Thank you for the patience and the consideration
I will also link here other players report:
(You can also see that all the players involved put the code recently, highlightning that it’s only a recent issue)

Please don’t cross post topics, thanks