Secondary GPU being used instead of primary.

I have a GTX 970 running alongside a GTX 760 and Halo Wars 2 refuses to use my 970. There aren’t any options in the menu to change GPU and I can’t find any option in the Nvidia control panel to force it to use my 970. Does anyone know any other way to force it to use my 970 instead of the 760?

remove it

I use the 760 for a VM that runs most of the time so I can’t simply remove it.

Nvidia control panel , go to manage 3D and it should have select preferred graphics processor see if that lists your GPUs and select the correct one.

That doesn’t allow you to switch between Nvidia GPUs just Nvidia and a non dedicated GPU(such as Intel HD).

> 2533274875405716;5:
> That doesn’t allow you to switch between Nvidia GPUs just Nvidia and a non dedicated GPU(such as Intel HD).

Not sure then, when developing the graphics engine you use adapter enumeration to find an adapter that supports the game unless they specifically include a setting to choose the higher card model then your somewhat out of luck. Look for a external program that can trick directx into thinking the adapter isnt there?

The code they use is like the following:

> if (SUCCEEDED( D3D12CreateDevice(adapter.Get(), D3D_FEATURE_LEVEL_11_1, _uuidof(ID3D12Device), nullptr)))
> {
> break;
> }

As soon as it finds an adapter it quits the loop and creates it, doesnt really care if its a newer or older card :confused: ask the developers i guess or find a tool.

> 2533274875405716;1:
> I have a GTX 970 running alongside a GTX 760 and Halo Wars 2 refuses to use my 970. There aren’t any options in the menu to change GPU and I can’t find any option in the Nvidia control panel to force it to use my 970. Does anyone know any other way to force it to use my 970 instead of the 760?

I’m hesitant to jump on the bad port band wagon but the Xbox can only have one display so the game will most likely only render to the primary display. assuming you have multiple monitors you should go to Geforce Control Panel, select ‘Display’ - ‘Set up multiple displays’ locate a monitor that is connected to your GTX 970 and right click and select ‘Make primary’ then select ‘Apply’ and ‘Yes’. Whilst it shouldn’t be necessary I would then close Geforce Control Panel, right click on the desktop and select ‘Display settings’, here you should confirm that ‘Make this my main display’ is ticked.

With this done, assuming you launch the game and it is displaying on your monitor (or TV) which is connected to the GTX 970 then the game will be rendering on that GPU.

Hope that helps!

Psi

> 2533274805501449;7:
> > 2533274875405716;1:
> > I have a GTX 970 running alongside a GTX 760 and Halo Wars 2 refuses to use my 970. There aren’t any options in the menu to change GPU and I can’t find any option in the Nvidia control panel to force it to use my 970. Does anyone know any other way to force it to use my 970 instead of the 760?
>
> I’m hesitant to jump on the bad port band wagon but the Xbox can only have one display so the game will most likely only render to the primary display. assuming you have multiple monitors you should go to Geforce Control Panel, select ‘Display’ - ‘Set up multiple displays’ locate a monitor that is connected to your GTX 970 and right click and select ‘Make primary’ then select ‘Apply’ and ‘Yes’. Whilst it shouldn’t be necessary I would then close Geforce Control Panel, right click on the desktop and select ‘Display settings’, here you should confirm that ‘Make this my main display’ is ticked.
>
> With this done, assuming you launch the game and it is displaying on your monitor (or TV) which is connected to the GTX 970 then the game will be rendering on that GPU.
>
> Hope that helps!
>
> Psi

My primary monitor is connected to my 970 and it is set as such in the Nvidia control panel and Windows. Using MSI Afterburner to show GPU usage while playing shows only the 760 having any major activity(100% usage, max boost clock speed and 4gb VRAM usage) while my 970 is barely above idle usage outside of being at full clock speeds(not boost clock speeds though).

> 2533274875405716;8:
> > 2533274805501449;7:
> > > 2533274875405716;1:
> > > I have a GTX 970 running alongside a GTX 760 and Halo Wars 2 refuses to use my 970. There aren’t any options in the menu to change GPU and I can’t find any option in the Nvidia control panel to force it to use my 970. Does anyone know any other way to force it to use my 970 instead of the 760?
> >
> > I’m hesitant to jump on the bad port band wagon but the Xbox can only have one display so the game will most likely only render to the primary display. assuming you have multiple monitors you should go to Geforce Control Panel, select ‘Display’ - ‘Set up multiple displays’ locate a monitor that is connected to your GTX 970 and right click and select ‘Make primary’ then select ‘Apply’ and ‘Yes’. Whilst it shouldn’t be necessary I would then close Geforce Control Panel, right click on the desktop and select ‘Display settings’, here you should confirm that ‘Make this my main display’ is ticked.
> >
> > With this done, assuming you launch the game and it is displaying on your monitor (or TV) which is connected to the GTX 970 then the game will be rendering on that GPU.
> >
> > Hope that helps!
> >
> > Psi
>
> My primary monitor is connected to my 970 and it is set as such in the Nvidia control panel and Windows. Using MSI Afterburner to show GPU usage while playing shows only the 760 having any major activity(100% usage, max boost clock speed and 4gb VRAM usage) while my 970 is barely above idle usage outside of being at full clock speeds(not boost clock speeds though).

Maybe there using multi adapter feature of dx12? so the load is shared between GPU’s

https://msdn.microsoft.com/en-us/library/windows/desktop/dn933253(v=vs.85).aspx

> 2533274854326472;9:
> > 2533274875405716;8:
> > > 2533274805501449;7:
> > > > 2533274875405716;1:
> > > > I have a GTX 970 running alongside a GTX 760 and Halo Wars 2 refuses to use my 970. There aren’t any options in the menu to change GPU and I can’t find any option in the Nvidia control panel to force it to use my 970. Does anyone know any other way to force it to use my 970 instead of the 760?
>
> Maybe there using multi adapter feature of dx12? so the load is shared between GPU’s
>
> https://msdn.microsoft.com/en-us/library/windows/desktop/dn933253(v=vs.85).aspx

While playing it sits at 10-15% usage which is barely more than playing back 1080p60fps Youtube videos(although it is at full clock speed vs the half clock speed it runs at while playing Youtube videos). If it was actually using the mutli GPU feature I assume that both cards would show load.

> 2533274875405716;10:
> > 2533274854326472;9:
> > > 2533274875405716;8:
> > > > 2533274805501449;7:
> > > > > 2533274875405716;1:
> > > > > I have a GTX 970 running alongside a GTX 760 and Halo Wars 2 refuses to use my 970. There aren’t any options in the menu to change GPU and I can’t find any option in the Nvidia control panel to force it to use my 970. Does anyone know any other way to force it to use my 970 instead of the 760?
> >
> > Maybe there using multi adapter feature of dx12? so the load is shared between GPU’s
> >
> > https://msdn.microsoft.com/en-us/library/windows/desktop/dn933253(v=vs.85).aspx
>
> While playing it sits at 10-15% usage which is barely more than playing back 1080p60fps Youtube videos(although it is at full clock speed vs the half clock speed it runs at while playing Youtube videos). If it was actually using the mutli GPU feature I assume that both cards would show load.

Hmm guess you can rule that out, must just be targeting the first supported adapter.

Not totally sure of this specific issue but the team has told me that Halo Wars 2 doesn’t currently support multi-GPU systems. It will only utilize one (though in this case I see you want it to utilize the other one). True multi-GPU support is something the team plans to implement post-launch.

> 2780570662795584;12:
> Not totally sure of this specific issue but the team has told me that Halo Wars 2 doesn’t currently support multi-GPU systems. It will only utilize one (though in this case I see you want it to utilize the other one). True multi-GPU support is something the team plans to implement post-launch.

It most likely is the first supported adapter being chosen to run the app causeing the “problem”.

> 2533274854326472;13:
> > 2780570662795584;12:
> > Not totally sure of this specific issue but the team has told me that Halo Wars 2 doesn’t currently support multi-GPU systems. It will only utilize one (though in this case I see you want it to utilize the other one). True multi-GPU support is something the team plans to implement post-launch.
>
> It most likely is the first supported adapter being chosen to run the app causeing the “problem”.

If that is the case simply disable (not uninstall) the 760 in device manager temporarily to see if it will indeed run on the 970. Later (preferably after a reboot) re-enable the 760 and see if it sticks.

> 2533274805501449;14:
> > 2533274854326472;13:
> > > 2780570662795584;12:
> > > Not totally sure of this specific issue but the team has told me that Halo Wars 2 doesn’t currently support multi-GPU systems. It will only utilize one (though in this case I see you want it to utilize the other one). True multi-GPU support is something the team plans to implement post-launch.
> >
> > It most likely is the first supported adapter being chosen to run the app causeing the “problem”.
>
> If that is the case simply disable (not uninstall) the 760 in device manager temporarily to see if it will indeed run on the 970. Later (preferably after a reboot) re-enable the 760 and see if it sticks.

Sounds like a good idea to me, jimbot post back if that works.

> 2533274805501449;14:
> > 2533274854326472;13:
> > > 2780570662795584;12:
> > > Not totally sure of this specific issue but the team has told me that Halo Wars 2 doesn’t currently support multi-GPU systems. It will only utilize one (though in this case I see you want it to utilize the other one). True multi-GPU support is something the team plans to implement post-launch.
> >
> > It most likely is the first supported adapter being chosen to run the app causeing the “problem”.
>
> If that is the case simply disable (not uninstall) the 760 in device manager temporarily to see if it will indeed run on the 970. Later (preferably after a reboot) re-enable the 760 and see if it sticks.

In the past if I disable a GPU I’ve had to reinstall my drivers for it to re-enable without the card behaving weirdly(mostly not downclocking when idle or getting stuck at idle clocks) but I might give it a try later today.