Problem Champion, Bullseye Packs?? "SOLVED"

I’ve had the same problem ever since champion pack came out. When I did not get help anywhere I became frustrated and angry. So after months of searching and swearing, I think I solved it! (for me anyway)

Try this:
Go to settings , system, storage and hard drive. Then go the folder games and apps, find Halo 4 and go in there to remove everything related to Halo 4.
I took away :
Bullseye Pack ( downloaded items)
War Games ( downloaded items)
Spartan Ops Season 1.0 and 1.5 ( downloaded items)
Halo 4 Title Update (update)
Forge Island ( downloaded items)
All, Halo 4 data ( saved games)

Then go back to the HDD menu , and enter to Profiles . Remove your profile.

Go back to the HDD menu , and go to the System Items .
Remove everything that is there :
Content Cache System ( Item )
The Marketplace - system data (system Item )
Remove everything and everyone !

Now go back to Storage Devices, where you select the yellow Y button ( device options ) from the hard drive. Not from your Cloud !
Now you need to Clear System Cache , 3 times in a row .

Download your profile again and run Halo 4. And download everything it asks for when needed. Then last of all download your Bullseye -Pack or Champion Pack again , so it should work . It solved my problem anyway hope it does for you too.