!! POTENTIAL PERFORMANCE FIXES !!

I had the same performance issues some here are experiencing, but I actually fixed mine. I’ll show you what I went through to fix those. I don’t know what steps actually solved it, but I hope these help you.

  1. Disable HDR through Xbox Game Bar. You can do this without launching the game. My main monitor has HDR enabled all the time due to this thing. Press the Windows Key + G and go to the settings (top right). From there, go to “Gaming features” and click “Use HDR with compatible displays.” Disabling this while the game is open will make your game look hideous, so I encourage you do this when the game is closed.

  2. Launch as administrator & disable fullscreen optimizations. In your Steam library, right click on Halo Infinite - Insider, click on Properties, click on Local Files, then click on Browse in the top right corner of the new popup box. From here, you will want to find the executable file. It is named HaloInfinite.exe. Right click on this file, then select Properties once again. Now just click on Compatibility and you’re now where you need to be. The two settings are looking for are in the bottom of the popup box. Click both “Disable fullscreen optimizations” and “Run this program as an administrator.” There should be check marks in the boxes. Once that is finished, you can now click Apply in the bottom right corner.

I hope this helps. I went from a slide show to 90FPS on high settings, and I only have a 2070 Super. Those guys with 3090s can hopefully now play the game. Just please stop destroying me in every game, thanks. :slight_smile:

EDIT:
There was one other thing I forgot to mention. When you’re in your Xbox Game Bar, I suggest turning off the constant recording settings. When in the settings of the Xbox Game Bar, click on Capturing and turn off “Record in the background while I’m playing a game.” I suggest keeping this off at all times.

I laughed way too hard at that last sentence. Lol
I will try this with my issue.
Thanks for the info!

This definitely sorted out my issues. Thank you kind sir!

> 2535420200485549;3:
> This definitely sorted out my issues. Thank you kind sir!

Glad I could help. :slight_smile: