Not working now, oddly...

I can’t find anyone, and when I press back to go to the menu I get stuck on “Leaving Matchmaking” forcing me to reset the whole game. Also I am now unable to invite anyone to my game!

Any one else having this problem or now how to fix?

I was getting consistent Big Team Battle games with 2-3 minute search times all night, but now I can’t find a BTB game at all. Just “Searching for players…” and then “Searching for more players…” forever. About a 5 minutes ago I got “Players found…”, “Connecting session…”, “Joining games…”, and then it went back to “Searching for more players…”. Every playlist other than BTB works for me though.

So annoyed with this game.

Just fixed it… Got to make sure you have Open NAT

> 2533274816651802;3:
> Just fixed it… Got to make sure you have Open NAT

Thanks for the tip, but I do have an open NAT. It seems like BTB works up until a certain time every night, doesn’t work until the next morning, breaks again late at night, and the cycle continues. This has been my experience for the past couple nights at least.