No game progress, medals or achievements being recorded at all in MCC!

Hello everyone.

This is my first post here, and I just delved Into the world of Halo.
With the release of Infinite, I thought I would get into the universe and story by playing all the games
and therefore I got myself MCC on PC to start my journey.

However I have run into a hugely annoying issue.

None of my progress is logged in the game… I completed the Reach campaign on multiple difficulties and played a bit of CE…
I tried playing several playlists, playing the whole thing in one setting, selecting single missions and every possible way to play I could think of - But no matter what, none of my activity is logged. My game time is stated as 0 hours across all games and gamemodes, I have no medals, no kills no nothing. Also no achievements unlock for me at all. I have also tried looking at the stat tracking site, and It shows zero activity across the board as well.

I have trawled the net and tried all the possible solutions I could find - Everything from whitelisting websites, editing the windows host file, making sure score tracker was on, doublechecking my firewall settings, and making sure the windows apps were running in the background.

I’ve pretty much run out of ideas now.

My other games on the Microsoft Store/Xbox app track achievements and progress just fine - Including Halo Infinite, which I played a bit of MP in, before deciding to start from the beginning and make make my way to the present.

Is there any help to be found, or is this jus the way it has to be?
I was really looking forward to building up my “legacy” :frowning:

Thank you in advance for your time and help.

3 Likes

I have pretty much the same issue with Halo Wars and Halo Wars 2 playing them through the Xbox App.

I play Halo MCC and Halo Infinite through Steam and the achievements there unlock both on steam and on my xbox account, it’s just the Xbox App/Microsoft Store that seem to be completely broken for achievements.

1 Like

So your ingame progress is tracked correctly on steam?

1 Like

Yes, I’ve played MCC on steam since Reach released, and before that time I’ve never played it on xbox. All my progress that I do playing through steam, including achievements, playtime, total missions completed, total playlists completed, campaign medals earned etc. are tracked properly on my XBL account when playing through steam.

Having said all that, I’d strongly recommend opening a support ticket which you can do by going to here:
support.halowaypoint.com

Click on “Halo: MCC”, if your issue isn’t listed anywhere, which in this case it will not be, click on any article under “General” and scroll all the way down where you should see “Ready to report an in-game issue? Submit a ticket”

Hopefully they are able to help you, if they do please do get back to me on what fixed it for you, I can’t send a ticket as HW and HW2 aren’t an option for doing so.

Thanks for the info! But that makes me wonder even more why it doesn’t work through Microsofts platform :face_with_monocle:

I know that this seems like a “No Duh” question, but you are sure that you were playing with Easy Anti-cheat enabled? I’m sure you where, but I just had to say that in case.

Having played on both Series S and PC, I the only problems that I have ever personally had with progress tracking was:

  1. An achievment for the Par Time on “Tip of the Spear” not unlocking on Steam, despite having been marked as completed on MCC.
  2. A challenge not keeping track of progress done to it, back when challenges where first added to MCC.
  3. Halo 4’s Spartan Ops not tracking Difficulty Completed progress.

On all three, I put in a support ticket. Of the three, only the last one was not solved (and still isn’t fixed yet). My advice is to put in a support ticket. Make sure to give a complete, 100% versbose description of everything you have tried so far. Everything. Even if it was “relaunched the game” or “reinstalled the game”. Also include a list of programs that where running along side the game (such as Discord or Skype), as whatever you where running could have flagged the Anti-Cheat. Knowing what you have already done will help support either guide you through what you haven’t done yet, or pass along detailed information to the developers do they can identify and (hopefully) rectify the rare glitch in the next patch.

Good luck, Spartan, and welcome to the world of Halo. I hope you are able to properly experience this wonderful series soon.

1 Like

Is not exactly same problem but I lost my LASO save, it no longer saves, when I retried it, just the time to lunch, when I came back the save have just disappear. A bit angry I purged all local saves and my steam cloud data, after done, was’nt able to save any unlocked stuff or any config (keyboard config, mouse sensitivity/controller config, gfx configs, audio configs…resetting to zero everytime :cold_sweat:, and all other preferences too including character customization & H4 loadout of course).
And a morning, oh magical divine interaction: The problem has been auto-fixed after a computer restart :astonished: :thinking:

So, now im not sure to would try again a LASO selection if its for re lost it for un unknown reason. If someone have encountered this problem and firmly solved this he can “honk” me with pleasure^^ so that I/we could have working LASO saves :smiley: