Multiplayer lag but singleplayer runs fine? [PC]

Hey everyone,

I recently picked up the Halo Wars 2 ultimate edition on the PC and the game generally runs really well for me. I have an i7-4820k, 32GB Ram and a 980TI which works smoothly in singleplayer but as soon as a I try to play multiplayer in any of the modes the lag is insanely bad between 15-20 frames per second. Is this something to do with the servers or am I encountering some sort of bug, is anyone else having this issue as well? Thanks for everyone’s replies in advance.

Kind Regards,
Daniel

Yes is a known problem with the server. The forum is already full with reports. Please read and do not always open a new thread.

https://www.halowaypoint.com/en-us/forums/f0258e8001734968984e8b56990f8daf/topics/halo-wars-2-pc-issues/7f0863c2-cfea-4260-beb1-63b1714bf55b/posts

> 2535437251111116;2:
> Yes is a known problem with the server. The forum is already full with reports. Please read and do not always open a new thread.
>
> https://www.halowaypoint.com/en-us/forums/f0258e8001734968984e8b56990f8daf/topics/halo-wars-2-pc-issues/7f0863c2-cfea-4260-beb1-63b1714bf55b/posts

Sorry man I didn’t know will look around next time!

> 2533274861812090;3:
> > 2535437251111116;2:
> > Yes is a known problem with the server. The forum is already full with reports. Please read and do not always open a new thread.
> >
> > https://www.halowaypoint.com/en-us/forums/f0258e8001734968984e8b56990f8daf/topics/halo-wars-2-pc-issues/7f0863c2-cfea-4260-beb1-63b1714bf55b/posts
>
> Sorry man I didn’t know will look around next time!

No problem.

I understand you yes. It is already annoying as bad the server run.
One can only hope that they have managed the problem of the lags soon out of the world.