MS Store Unable to Install MCC

Hello, I’ve been unable to play MCC on PC (using the MS Store) since the Halo 3 addition to the MCC. I’ve searched high and low in the internet, in forums, and tried everything imaginable including sending feedback thru the feedback hub to no success (and no replies from MS). I’m trying a thread here as well as tweeting at some prominent Halo community members on twitter as a last-resort. I’ll detail the situation below.

First, I will mention, I have installed a fresh copy of Windows 10 (version 20h2). The only change I make from the stock install is to set all applications to install to a separate hard drive (Drive D:) because C: is a 120G ssd that can’t fit anything besides windows.

The issue:
What: Installing MCC thru the MS Store fails.
How:

  • I navigate to the Halo MCC page on the MS Store, click the Install button, then click on the “Downloads & Updates” button - The MCC, and all MCC titles populate in the Download Queue. One by one, each title goes thru the following steps: 1) Pending 2) Acquiring License 3) Downloading 4) Error - Clicking on the Error Details for the Master Chief Collection install yields: "This app or game requires more room than your drive has available. Code: 0x80070070"Machine Details:
    CPU: AMD FX-8350
    MOBO: asrock 990fx killer
    GPU: Radeon rx 580
    RAM: 2x 8GB ram
    OS: Windows 10 Pro
    HDD 1: PNY 120G SSD - used for windows install only
    HDD 2: WD Blue 320G HDD - used for applications & user home directory
    HDD 3: WD Blue 500G HDD - used for backups

As mentioned above, I have tried every suggestion I can find on the internet, I have tried all kinds of my own hacking around but I can’t get it to work. I’m open to any and all suggestions, please help!!

Note: I have set windows to save all new app installs to the D: drive and applications successfully install to D:\WindowsApps and D:\Program Files\ModifiableWindowsApps but Halo is the one thing that refuses to install and work successfully. I have done a clean w10 install by deleting all partitions on it, reformatting it, and then installing windows from a USB ISO and the same issue persists.

Hey OP, I would recommend heading over to https://aka.ms/HaloSupport for further assistance. Please review the latest known issues and submit a ticket if your issue is not listed.

Thanks!