Menu not loading . battlepass, store, spart armor hall all not working

Tried resetting, restarting modem, clearing cache and reinstalling game. Help please.


The UI does not fully load, the icons do not load. I don’t purchase anything from the store, but in any case, the store does not load, just empty pallets. The menu not functioning correctly has been a problem since launch, if they are unable to build a properly functioning UI … do I need to state the obvious???


Same problem… can’t even equip the armor I paid for…


Guess I’m not the only one. Can’t see progress on BP after matches, says I’m on Season 0. Front end on game still tells me to purchase BP, even though I have. Vanilla armor during games, but can’t get to armor hall which is the whole point of BP! Even on Waypoint it’s damn sluggish. It was a bit buggy for season 1 and 2, but not like this.

Having the same issue on both PC and Xbox Series X. Any updates?

1 Like

Im having similar issues. Tried restarting, relogging, uninstall and installed but nothing seems to work. :confused:

I am having the same issue. Last night I was able to get into games, was not able to see battle pass progression, the store wasn’t loading, the news was not loading. My armor was gray as if I just started.
3 hours later the same night around 9pm eastern, my game loaded up fine. Everything worked. I had changed nothing.
Today I tried logging in, same issue. Can’t see my armor, news, store, battle pass. I searched the internet far and wide for a solution. I found nothing. I opened a ticket and am still waiting to hear back.

I’ve been having the same exact issue too. Can’t view the battle pass and challenges, store, customization menu, and my Spartan is the default with no customizations.

And this is ongoing with the March 15th update too.

1 Like

Since todays update im also locked out of lobby services and community and store wont load.

Yup, same issues here. Was hoping it wasn’t just me. Ridiculous that they released an update and this wasn’t top priority. Can’t even play at all and definitely am not going to try to get friends to play till it’s fixed.


Work is still ongoing on this one - it’s proving to be tough to repro and pin down. If anyone else sees this and has this same issue, please submit a ticket


Would be cool if they could acknowledge this issue

1 Like

See my post immediately above yours

1 Like

I love Halo, spent hundreds of $$$ in the store. Love to support. But, it’s been a long time now, still can’t equip any of my armor or load the store… this is an absolutely horrible customer experience.