MCC will not let me download through app store

I’ve been trying to download MCC for pc and it will not let me download the game, it just keeps coming up with a message when I try to download MCC saying
Where do you want to install it looks like you don’t have any applicable device(s) linked to your Microsoft account. to install, sign in on a device with your Microsoft account.

I’m using my account that I use to download all my games off the app store. they all work perfectly fine. the Xbox game pass for pc app will not install on my computer for some reason so I’m kinda out of options here.

I am running into the same issues. I renamed my pc. I also logged into my Microsoft account and checked my devices. I also went to uninstalled and looked at the Microsoft store app. You cannot uninstall but you get an option to repair, terminate. I tried it all and it did not work. I even went into the xbox beta app and choose the drive I’d like to install the thing and it gave me an error code 0x00000001. I looked up the error code and its some sort of blue screen error for everyone else. I try launching other games and its wanting me to download gaming services every time. I’m thinking of a system restore but I really don’t want too. Microsoft app store is a pain in the -Yoink-. I’ve never had issues on any operating system except windows. Any way can anyone think of anything that maybe causing this?


I have same problem. I can’t do anything.

I can’t download the game. When I download halo reach is download only 10 mo.
And if i try to update / install halo : collection it’s still loading ( and i can’t do anything.

I have try with microsoft store and xbox beta app and same problem.

I have buy 40€ and i can’t download/play my game :frowning:

error: 0x803fb107

I found that I was unable to install Halo MCC (via Xbox Game Pass Ultimate) until I applied the latest feature updates for Windows 10. I’m now on version 1909 and suddenly installation worked just fine.

Perhaps try that?

Same issue, going to try out @graphicCash’s idea, have been getting blue screened and I am ASSUMING its because its techically not installed.

Screaming like a little girl!!! I got it to work. System restore my pc and it did not work at least at first.I got frustrated and started clicking the -Yoink- out of MCC and it started to download. i was having trouble with the microsoft store and this vid helped.