MCC Language issue

Ever since the new update launched, my ingame language switched from English to German. I am from The Netherlands where we speak Dutch, so I find it odd that the game is in German for me. I’ve tried changing my console settings to english, changed my country to England/USA but the game stays in German. Is there a possibility to change this because I do not understand any German at all.

I got the same problem … but i live in sweden

Change your console settings and your country to english and reinstall the game. That worked for me as well (ook nederlands).

Come on Dutch Mickey, why not become trilingual and learn a bit of german too :wink: