I'm having issues in forge

I’m having an issue in Halo 5 forge because every time I put an object near another one they clip together. I know it’s not a bug but I need help on how to disable and enable.

There should be an option that allows you to disable the “snap-fit” ability when putting things together.

While in Edit Mode in Forge, (Monitor Mode), hold down the left trigger, and while doing so, press Up on the D-Pad. This enables and disables the Magnet Tool in Edit Mode.

You can also tweak the Magnets a little more by pressing X while still in Edit Mode, and selecting Tool Settings. There you can turn the Magnets on or off, and also change the Magnet Strength.