How to stop auto sprinting after throwing a grenad

I find myself continuing to run into an enemy team when I mean to stop and just walk peak or something. I have maintain sprint turned off