HCS Grassroots Tournament Organizer App. is broken

Hi, my company is trying to apply for the Halo Grassroots platform but the webpage seems to be not working when trying to fill out an application. I made a new microsoft account and it worked the first click but I want to submit our application through this account. Can you help me with that please? Thank you.

Go to: https://www.halowaypoint.com/en-us/esports/grassroots

Click “Tournament Organizer Application”

Error message recieved: “PROBLEM DETECTED Well, this is embarrassing. Looks like we have some problems on our end.”

I would like to submit our application under my normal Halo Waypoint account. Thank you.

I’ve already talked with Microsoft Support and Xbox Support. They both said they couldn’t help me.

Page seems to be working ok for me now OP, can you try again?
If it still doesn’t work, try either clearing out your browser cache and cookies or using incognito mode

Still doesn’t seem to work for me. I’ve cleared cache and cookies, used a different browser, used a different computer, etc.

It seems to be an account issue where you can only click the button once or something.

Thanks for your reply though.