Have Map pass, Can't download maps.

I bought the Halo 4 map pass and now I can no longer download them for free. I go the the market place and it says I have to pay as per what the Xbox websites states. However the maps are no longer in the in game store I can’t download them there. Anyone know how to resolve this?

Castle
Majestic
Crimson

Hope these links work.

Says I have to buy them with Microsoft points.

Odd, how did you get the Pass, on the marketplace or a prepaid code?

I bought it off the market place. I also have a code that came with the limited edition.

Did you redeem the code from the LE before buying the pass of the Marketplace?

Also, if you have one, why buy the other?

I bought the map pack and then redeemed the code. When I bought the map pack at the time the limited edition one wasn’t going to come with the helmets.

As far as I am aware, we have known that the LE map pass came with the Helmets since launch, so that means you must have bought the Pass from the marketplace back then.

Check the terms and conditions, about how long you have to download them, there could be a used-by date.

Just curious as to why you haven’t tried to download them yet?

I bought the map pack before launch. And I redeemed the code the day of launch. The reason I’m trying now and not when they came out is, when is played it didn’t feel like halo to me. However I’ve been reading that there have been changes and I want to get back into playing it.

Ok. Not a lot I can suggest really other than contacting MS support :frowning:

This has been an issue for a long time and has a solution that has worked for many people.

  1. Go onto your Xbox hard drive and delete the Map Pass and any map packs you already have.

  2. Go into your download history and redownload the Map Pass.

  3. Load up the game. You should be prompted to download Map Pass content.

  4. Download and enjoy (or don’t since the maps almost never show as voting options).

Hope this helps.

Just to make sure–you are accessing the map packs through the game, right? On the main menu?

Been looking for a fix for some time now for this thanks Phil