Halo Wars and Halo Wars 2 XGP (PC) Version Crashes

I recently signed up for the Xbox Game Pass program and I was really looking forward to playing both of the Halo Wars games. Unfortunately, both of the games launch briefly before the window just disappears and I get no error message or anything. I have tried everything and I can’t seem to figure out what the issue is.

I tried disabling Avast because it was also causing issues with a few other games in the Game Pass library but disabling Avast worked for those other games and not for Halo Wars or Halo Wars 2 so I am not sure that is the issue. I made sure all my drivers are installed and updated and I made sure I have DirectX 12 installed. I have a fairly beefy gaming laptop and Halo Wars 2 is a 2 year old game and Halo Wars 1 is even older, so I doubt the problem is just that my pc can’t run it. Just in case though I will paste in the basic info from my DxDiag report I just ran below. The only other thing I could think it may be would be that I have the games from the games pass library being installed into a secondary HDD installed in my laptop because it only came with a 250GB SSD so I installed a 1TB HDD and that is where I basically have every game installed on the laptop. But as I have stated before, it hasn’t caused any issues with any of the other game pass games.

If anyone could get in touch with me it would be greatly appreciated. I just really want to play these games.


System Information

Time of this report: 7/6/2019, 13:15:26
Machine name: MATTPREDATOR
Machine Id: {724AEF6C-E1A9-4F4E-9434-B6BE38251554}
Operating System: Windows 10 Home 64-bit (10.0, Build 18362) (18362.19h1_release.190318-1202)
Language: English (Regional Setting: English)
System Manufacturer: Acer
System Model: Predator G3-571
BIOS: V1.09 (type: UEFI)
Processor: Intel(R) Core™ i7-7700HQ CPU @ 2.80GHz (8 CPUs), ~2.8GHz
Memory: 16384MB RAM
Available OS Memory: 16268MB RAM
Page File: 10011MB used, 8688MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 12
DX Setup Parameters: Not found
User DPI Setting: 120 DPI (125 percent)
System DPI Setting: 120 DPI (125 percent)
DWM DPI Scaling: Enabled
Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Supported
DirectX Database Version: Unknown
DxDiag Version: 10.00.18362.0001 64bit Unicode

It happens occasionally.
Because most of the error of Windows user authentication is happening
It is recommended to re-authenticate the user in Windows settings.