Halo 3 Tsavo Highway Glitch

Hi,
I feel kind of bad that my first post on these forums is a moan.

I have been doing the Solo Legendary Play through of Halo 3 (a bit late I know), however although I completed Tsavo Highway and the following missions a few nights ago, today Tsavo Highway was showing only done on Heroic. I completed it again today and still no joy. I have been onto Live Support and done all the troubleshooting steps they have recommended, including deleting profile, game and cache and reloading. Unfortunately our efforts were fruitless and it still doesn’t register that I completed it the other night.

I have now been advised this could be a bug with the game, and to raise a thread here.

Why not just replay it on Legendary? It takes literally 20 minutes.

Are you able to give us a screenshot by chance?

Also did they have you check for any yellow “!” files that could possibly be corrupt?

Is it showing trouble with any of your other stats?

We hope the reason we haven’t heard from you is because your issue has been resolved. If your issue has not been resolved, please start a new thread.