HALO 3 CO-OP COOP campaign unplayable

Typing to document my experiences with Halo 3 Coop campaign issues:
My friends and I are not able to play campaign together. If the game loads in we might get a few minutes of game play before it boots everyone back to menu saying connection interrupted.

We’ve tried forwarding Xbox Live ports directly to our individual PC’s instead of letting router do it automatically via uPnP.
We tried cutting out the Xbox live services as well and played via a VPN’d LAN connection with no success.
Changed difficulties around, enabled and disabled skulls.

I simply think its just a synchronization issue between applications and i have no idea how to proceed further. I just want to play Legendary Co-op with the bois.

We have this issue too! We got around it by swapping hosts, but that wouldn’t always work. Would love a patch

I keep getting lag whenever I play with others. me and a random got booted out because of the lag. I have no issues on the PVP side of the game, but campaign is almost unplayable. This needs to get patched. I’ve had this issue with the other halo’s as well

Tried running coop with four players. Every single time, got kicked back to menu some point in the first 3mins. Three players were in the UK, one in northern Europe, slightly further but they’ve never had enough latency for notable lag. We tried with multiple different hosts, all failed.

Later on, I was able to play 3-player coop just fine with two other people, both were in the UK.

Seems to be either very slight lag is able to end the game, or four players puts it over the lag threshold.

I’ve had the following issues with co-op.

  1. Connection issues, which includes lag and 5 second stop of action for everyone playing with me.
  2. Sometimes when playing a campaign I experienced the one mission skip (I was loading to The Storm and it showed me the Tsavo Highway instead). This also includes the challenge progress.
  3. Once everyone in the game got kicked all of the sudden without a reason.
    That might be it for me, though I have played only up to Floodgate in a single session of co-op.

Also having this issue, will try swapping hosts

EDIT - I moved my game to my OS drive (SSD) and it appears to have fixed the problem