H3 MCC "Missing content" message

I have Halo MCC on PC through gamepass. I have very game downloaded but when I go to play Halo3, I get a message that reads “missing content. The following content is not installed :Halo3.” This takes me to the manage games option and it shows me that Halo 3 is indeed installed.

It appears as installed on Xbox app, Microsoft Store, my external HDD, and within the menus of the game itself. But as soon as I go to play H3 (this applies to Campaign, Multiplayer and Custom Games) I get that same error message telling me that the content is not installed. I have unistalled and reinstalled H3 and MCC repeatedly to no avail.

Anyone else had this issue and any fixes to it?

Hello OP did you ever solved this? i’m having exactly the same trouble playing

The problem seems to come from a faulty sync of your Microsoft account’s rights and permissions. The solution: (1) log out of the Windows Store, (2) log in to the Windows Store, (3) launch the Halo MCC. In my case, I’ve also logged out of my Windows session after (1), launched the game before (2) and the relaunched the game after (2). It solved the problem.