Guide Not Working Properly

Morning everybody. This morning when I got around to watching Nightfall I noticed that once I started the video I lost all ability to access the menu guide. I wasn’t able to pause the video and when I brought up the guide it was just a blue box on the bottom half of the screen. Then when options came up for the Second Story I opened that up but wasn’t able to access anything, and once again the blue box on the bottom of the screen came up.

I then tried to access a terminal video from the MCC directly. The video played fine but when it ended I opened the guide to watch another one, and the same problem: another blue box. Somehow between mashing buttons I was able to start the video over again but then I lost all ability to use the video controls, i.e. I couldn’t pause, rewind or stop the video altogether.

Is there something wrong with Halo Channel that would be causing this?

Hi Skippy575,

Have you tried restarting Halo Channel to see if this resolves the issue?

Yes I have. I tried twice to restart Halo Channel, and then I tried restarting my Xbox altogether and that still didn’t work.

Update: I tried it later this afternoon after lab and it works like it should.