getting kicked from multiplayer lobby

okay so what’s is i go into arena or warzone it will find people connect to the dedicated server then say "game loading its say that for like 10secs then kick me back to the arena menu screen. then 5sec later and error message pops saying “unable to join the request has timed out” this is what i have tried to fix it

i have att uverse and a belkin router live in the U.S. getting 23mb down & 5mb up i have OPEN NAT (wired powerline adapter brand is tp link)
(i am apart of the new Xbox one experience program so)
the thing i have tried to do to play multiplayer:

-hard reset my Xbox and unplugged it doesn’t work

-unplugged Ethernet doesn’t work

-reset modem and router works for 2 games

-change DNS to google’s DNS servers doesn’t work

  • cleaned the disc doesn’t work

-re-uninstalled halo 5 doesn’t work

-clear mac address doesn’t work

-switched to wireless works for 2 games
then switched back to Ethernet works for 2 games

thanks 343 in the future when you fix this!!!