Error in Reach??

For some reason; I’m unable to view Challenges, enter Matchmaking and my Spartan has reverted to default Noble Six. It displays a message (in the Matchmaking lobby) telling me that the server is unavailable, but I have not received any other pop-up message.

With my Xbox Live cable disconnected; my Spartan appears as he should be. However, when I connect to Live, it immediantly toggles to the state as if the server is offline.

Any advice?

Try resetting your network completely.

@snickerdoodle - trying that now;

I’ve already cleared the cache; and tried recovering my profile (twice) :confused:

Hopefully it works! I find that sometimes when I’m having issues like that, I have to take a break for a bit to let things fix themselves. That said, not everyone is so lucky, which stinks. :frowning:

I guess I can count myself amoung the lucky ones. That idea worked, snickerdoodle.

Thanks a lot. :slight_smile:

No problem, glad it worked out for you! Happy hunting!

Glad it worked out for you, think I’m going to try recovering and cache clearing AGAIN when I get home this evening… Appreciate the link, Snicker.