Default Spartan Image

My Halo 4 stats keep showing the default Spartan in red Recruit armor. Anyone else have the same issue? My avatar spartan image is fine, though.

Its the same for me to. Don’t worry, its probably just a server issue, i am sure a lot of people have it.

I’ve had it ever since i bought Halo 4, is there any way to fix it?

Never mind, i bought a new xbox because my last one broke, and it has a hard disk on it. I think that’s what fixed it.

No problem for me

I have a the problem

I don’t know why it does that :frowning:

It is not good.

But halo is my gane though…

<mark>This post has been edited by a moderator. Please do not bump.</mark>

*Original post. Click at your own discretion.

…it will always be forever…and ever…

<mark>This post has been edited by a moderator. Please do not bump.</mark>

*Original post. Click at your own discretion.

…does some one know how to fix this?

<mark>This post has been edited by a moderator. Please do not bump.</mark>

*Original post. Click at your own discretion.

Just so mad, I wish they would care

<mark>This post has been edited by a moderator. Please do not post spam.</mark>

*Original post. Click at your own discretion.

By the way…I’m not spamming

<mark>This post has been edited by a moderator. Please do not post spam.</mark>

*Original post. Click at your own discretion.

Just mad…bruh stop hating

<mark>This post has been edited by a moderator. Please do not post spam.</mark>

*Original post. Click at your own discretion.

And i’m still at Recruit-Silver

<mark>This post has been edited by a moderator. Please do not bump.</mark>

*Original post. Click at your own discretion.

Can someone please help me :frowning:

<mark>This post has been edited by a moderator. Please do not bump.</mark>

*Original post. Click at your own discretion.

I guess noone cares.

<mark>This post has been edited by a moderator. Please do not bump.</mark>

*Original post. Click at your own discretion.

Well I do. But you guys don’t.

I have the answer.
either the servers are down.
or you change your armor too fast for it to update.
or you don’t have a hard drive.
i have the same problem except mine is green instead of red