Current Glitches

<p data-aria-label-part=“0”>This thread is a place to post any glitches you have experienced whilst playing Halo Wars 2.
<p data-aria-label-part=“0”>
<p data-aria-label-part=“0”>Campaign: stalls and can’t move every so often (5 times so far), graphics go very poor sporadically. This next bit has happened twice, and is very bad; After completing a mission, instead of moving to the next level, you are shown a cutscene which is the first one of the game, then the first mission “Signal” begins, and the entire campaign progress is wiped, this is not what a finished game should have at all! The Blur cutscenes which were promoted & bragged so much about are non-existent. After 8 missions so far, I have only seen two, the first two, this may be a glitch and they aren’t appearing. If not, this was marketed so badly, you would expect a cutscene at least at the beginning and end of the levels.
<p data-aria-label-part=“0”>
<p data-aria-label-part=“0”>Multiplayer is where there is a fortune: game crashes randomly, often towards the end of the mission forcing you to quit the whole game, units randomly begin moving backwards not that they have been told to but looks like they are being dragged they then move completely off the map seen only by their lights going away out of the gameplay area, wraith stalls randomly in the middle of the battlefield if teleported it is still stalled but can shoot, loading times for games and campaign are incredibly long and sometimes never load. RB doesn’t always work, and certain units are not selectable. This has happened several times. The game often stalls for a couple of seconds, potentially bad connections but this happens too regularly for this. Loading times & search times are incredibly long.
<p data-aria-label-part=“0”>
<p data-aria-label-part=“0”>General: The SGT Forge doesn’t download easily, and has crashed the Xbox several times. The home menu’s music is dodgy sometimes too.
<p data-aria-label-part=“0”>
<p data-aria-label-part=“0”>As with all things, there are others, but don’t come to mind at the moment. If you have had any errors, feel free to post below.

I haven’t experienced any of these “glitches”, and a download has nothing to do with the game. Your xbox crashing and some of these seem like it’s the xbox and your wifi’s fault. I have experienced the game not allowing me to use mouse/Kb control after reloading a save.

I keep getting constant video glitches. They’re giant triangles that always have one end pointing at the center of my hud and block a ton of the screen. I literally can’t see anything unless this gets fixed. Everything else has run well for me.

Yeah, having a few myself here. Sometimes warthogs get stuck in place and can’t move. Sometimes the campaign lags for 3-5 seconds. Other times the loading times for levels never ends, usually a restart of the game works. Right now I’m having an issue where the signal isn’t loading, the screen is black, I believe this happens if you skip the cut scenes before because when I don’t it works. That’s it for now.

I dont play online, dont even have online access at home, But I just had the most frustrating glitch. I made it to the third level, beat it, and then the next thing I see is the First Cut scene from “The signal” and then it loads up the first level again. I went back to the main menu, tried to load up saved data but it told me there was none.
Hours later, I turn it back on, and my save data is still gone but I can still access the levels Ive beaten. The whole glitch repeated over again when I beat the Cartographer.
Very frustrating, not what Im expecting for what these games cost. Not very happy with my XBO in general. :frowning:
Not very sure if im missing cutscenes either. Ive only seen 2 or 3 so far. I thought maybe theres one at the end or the begining of each level?

In the mission under the dark my kodiak glitched out and turned yellow off the point, HELP!

The game refuses to let me play as a leader in blitz and says that this deck is invalid.The reason why I think it is doing this is because it says I don’t have the cards that are in the deck when earlier I did and had to do that I could make the deck in the first place.

> 2533274894659558;7:
> The game refuses to let me play as a leader in blitz and says that this deck is invalid.The reason why I think it is doing this is because it says I don’t have the cards that are in the deck when earlier I did and had to do that I could make the deck in the first place.

Please don’t revive old topics thanks, there is a thread here that may help with your issue
https://www.halowaypoint.com/en-us/forums/f0258e8001734968984e8b56990f8daf/topics/missing-cards-from-deck/4d525739-ba35-4825-ba5d-fac706085be2/posts