Can't play multiplayer; Connection interrupted

Ever since last night, I have been unable to play any matchmade game. Whether it’s a custom game or a social game, it WILL NOT put me into a match. For instance, each time I try to join one of my friend’s custom game, I sit on a loading screen for about 5 minutes only to get the message “Your connection to the game session was interrupted.” I thought this was only an issue with custom games, so I tried joining a matchmaking game and I’m met with the message “You were removed from matchmaking due to an idling player in your party.” I have noticed that the MCC client stops responding each time it attempts to make a connection to any game session, which is probably the reason I get kicked for “idling”. Because the game freezes while trying to find a match, it then thinks I’m idle and proceeds to boot me from matchmaking. I have MCC installed on my SSD, so there should be no reason the game isn’t responding.

Here are all of the fixes I have tried:

  • Verifying integrity of game files (through Steam) - Reinstall MCC to a different drive (an SSD) - Delete MCC LocalLow AppData folder - Used the “Fix it” tool in Windows 10 Settings for Xbox Networking (not to mention that everything says connected, 0% packet loss, and moderate NAT type) - Used the “Change Profile” option in-game to sign out of my Microsoft account and sign back in - Restarted my PC multiple times - Restarted my router, flushed DNSI don’t know where to go from this point, I just want to play matchmaking again. 343 please fix this issue

You have described all of my problems perfectly and have also attempted all the fixes that I’ve attempted…
I’m flustered, I’ve had a ticket submitted for a week now and still no answers. Would love to play some games with my friends. If I turn relays on, sometimes I can get into a random game but it’s not 100% guarantee. This problem needs some support.

i have this issue. can’t connect to any games. I restarted my computer and unplugged my internet and tried getting in a game. got in one then after that just get the same error. not playing this game until this problem is fixed. its unacceptable.

I am also getting this, what the hell is going on 343i, Why are you not resolving this…

Same problem here