Cant get to title screen

Right since the ODST update my MCC has just stopped working.
At first it wouldn’t let me access the multiplayer with it constantly telling me it’s downloading the latest data, Now however when I load up the game, once it asks you to press the menu button it will disappear and just leave me with the background and no menu. So I can’t access any part of the game. Not even the music is working on this screen.
343 sort this out. You gave us ODST as an apology for the way the MCC has been run since release and now because of ODST, my copy at least has reverted to not working at all again

Have you tried hard resetting your console?

  • Quit all apps and games so you’re back at the dashboard - Hold the power button on front for about 30 seconds - Unplug the power -Yoink- and wait 1 to 2 minutes - Plug back in, switch on the box and load up MCC

Yes I have. I’ve performed a hard reset on both the xbox and the internet router. I’ve even un-installed and re-installed the game. Still not working