Cant get past start menu

First time this has happened since launch.

I hit start at the Halo 5 start screen after loading and it wont go anywhere. Sits there showing the infinity ship and bottom left loading. Anyone?

Same problem as you, although i was playing fine a few hours ago, now it’s title screen ‘loading’.

Happening to me to! As we speak! Fully “quit” the game and nothing. This is on top of the other problem where you couldn’t load a mission before it booting you to main menu, which I resolved by uninstalling the game and reinstalling…

…not not doing that again…

Update: After 4 minutes of it “loading” it worked. In campaign now.

Yup. I played not 3 hours ago. Now I can’t load in past the title screen

Same happened to me. I finally just let it sit there and spin. It finally loaded flashed up you don’t have permission to access then popped into the main screen. dunno what’s up but i’m finally in lol.

Same here. After a few minutes it loads.

Same here, was stuck on loading for maybe 5 full minutes before I got into the game. Tried restarting game and xbox, very slow but seems to work okay once past that screen.

So many bugs! Anyway, game works like it should now. Let it “load” for a few minutes at least people.