Cant get halo to use my 3070 rtx, will only run on integrated amd graphics , HELP

I have a asus duo running ryzen 5900 and a RTX 3070, 32GB RAM. My games plays at 35 FPS…

I used NZXT to determine if the game was using the wrong gpu, and confirmed that during gameplay it utilizes the AMD integrated at 99% and my 3070 at 0%. Ive tried everything to force it to use my 3070 but cant figure out what to do. All my other games in Orgin and steam dont have this problem and run my 3070 perfectly at high FPS., just halo.
Ive tried:
Disabling the AMD intergrated all together- literally makes the game run at 1-2 FPS
Updated all drivers
Updated to new halo AMD software
Turned on and off async
Added to high performance on graphics settings
uninstalled/reinstalled game/drivers
made sure in game settings to pick display adapter as 3070

not sure what else to try? can anyone help?

You could try disabling/modifying power management options.

tried this, no go, thanks tho

anyone else have this probelm with a 3070 + ryzen

Sounds like a configuration issue.

Review your settings, review the status of your IGU and GPU, make sure your drivers are good, and make sure your display device is connected to the GPU itself.

And by “settings”, I mean make sure the integrated graphics are disabled.

Edit: The only reason your GPU wouldn’t be doing any work is if the computer isn’t using it.

I’m pretty sure the 5900x doesn’t have an IGPU.

1 Like

why would every other game play normal and utlize the 3070 but not halo. not sure what setting would make the igpu only used, even with 3070 selected in game menu

Friend, I have no idea. I only offered these suggestions because I:

  1. Can’t physically inspect this person’s hardware or settings

  2. Don’t have a comprehensive understanding of Halo Infinite’s systems

  3. Can’t really offer deep technical advice due to not playing on PC myself

But I wasn’t talking out of my -Yoink!- when I said what I said. I meant what I said, because that’s what I’d do.

thanks for comments and help so far, anyone else have any other suggestions, appreciate the help

Have you tried updating graphics drivers?

i was able to add game to gefore exp but still not using my gpu, uninstalled and reinstalled updated drivers

I’m assuming this is a Laptop?