Cant download Halo App

I updated to the Windows 10 Anniversary, but even after that, I am unable to download the Halo app from the Store. When I go to the Halo App in the store, the option to get it is greyed out. I seem to meet the system requirements for the app, but in the store I see a message that says, “This app needs hardware your device doesn’t have”. Any suggestions?

Tried updated to Windows 10 Anniversary a second time and it seemed to update properly. I then went back to get the Halo App again and it seemed to work. Tried launching it and everything seems good. Problem solved, I guess.

Thanks for this report and keeping us updated - glad it worked for you!

I downloaded the app after the update so I could forge on my PC, and every time I open Halo 5 Forge, it says I could experience stability issues, then it closes every single time.

<mark>This post has been edited by a moderator. Because we are not currently equipped to provide moderation in other languages, we ask that all messages be posted in English. Feel free to use an online language translation service, and then create a new thread with the translated text.</mark>

Peut ètre que ton ordinateur n’est pas sufisament puissant.:wink:

The halo app when I was downloading it it had an error half way downloading I don’t understand what happend