Can't Connect to MCC?

Figured since I couldn’t find any reasons elsewhere I’d mention here: anyone else having trouble connecting? Around 1 PM CST it just… stopped. Attempts to play online were met with odd, infinite “Connecting…” screens. I figured my internet was having a rough time like it sometimes does, but come back almost 6 hours later and same deal. Couldn’t connect to the Waypoint either on my wi-fi, had to switch to data. Internet’s perfectly fine everywhere else though.

Anyone else having similar issues? My first thought was maybe I got banned for getting stuck in swordline games that I couldn’t quit out of without then getting quit-banned, but I imagine if I was banned it’d just tell me that instead of infinite screens of trying to connect.

Very interesting my buddy is encountering something similar. When he try’s to play online or campaign online it disconnects from game. We have no idea what to do he has game pass ultimate. We tried uninstalling reinstalling the game, tried installing just reach campaign and we can’t connect together