Can't buy Credits after last updates, Broken?

I know before the OP Hydra update and then fix, I could buy credits… Now it just hangs on “Connecting to a service” (after a minute I must click its back button, it won’t connect.

I tried buying some credit/gold in another game ASPHALT 7 HEAT and it worked, So whats up?

I’ve never been able to buy credits in game but you should be able to purchase them from the ‘Games’ App in Windows 8 now. That’s how I get CRs.

Hmm yea, I did as you mentioned and used the Game app instead and that worked… wonder whats up with the in-app purchases?

Are you unable to buy anything with currency? Just XP?

I can’t buy credit in-app using my Msft account, it won’t connect(screenshot)

However Microsofts Games app lets me purchase credits for Halo:SA without issue

What region are you located in?

Right now my region is set to Canada(where I’m physically located), often I’ll change my region PC settings to gain access to free Store apps restricted to other regions, yes I’m aware purchasing will not work unless the region(on PC) is set as the same region in my Msft account/payment details

I did install Halo:SA while my region was set to US(in control panel settings), but this did not cause an issue purchasing in-app prior to the last updates, I simply set my Store region to Canada and went ahead with some in-app CR purchases(they worked at the time)

Please look into it