Cannot play CO OP with friend: Session Interrupted

Tried for a half hour to play CE Anniversary CO-OP on the PC with a friend of mine. Every time we tried to load up the first level, it would kick us out of the lobby and tell us “session interrupted” or something like that.

My friend just got frustrated and refunded the game on Steam. Thanks a bunch, 343. This game is in an absurdly mediocre state and it boggles my mind that they spent so long porting this game for it to end up like this. It’s just unacceptable that a port of a 5 year game, that for some reason can’t even release all the games at once, is in such a miserable state at lauch.

I’m in the exact same boat. Honestly, I don’t see much of a reason to play Halo CE today beyond co-op with a friend. The reason I say that is because the multiplayer is pretty bland since it’s an older game, so there’s not much of an experience to be had there. All CE has going for it is its campaign, and they colossally screwed that up. So much for “it’s ready when it’s ready.”