Campaign Unavailable Through Game Pass on PC

I installed Infinite through the Game Pass app today, waited until around 2pm EST when the game was available in my region, and no luck. When I go into settings and click on “Manage Game,” the option to install the campaign is grayed out and it just says “requires purchase.” If I click on “campaign” on the main menu it just takes me to a preorder screen that opens up the MS store.

What gives? Are the servers busted? Does the game not recognize I’m running it through Game Pass because I have the multiplayer installed through Steam? As of writing this, it’s around 7pm and I’m still unable to install the campaign. This is incredibly frustrating.

1 Like

I uninstalled the game and reinstalled it, works for me. Sucks that had to happen to get there.

Well I suppose I can try that. Wouldn’t be so bad except the Game Pass app has incredibly slow download speeds. I’ll uninstall Infinite from Steam too, just in case that’s causing any weird conflicts.

1 Like

Im playing on pc with Game Pass. You need to open the ms store click on library and then click the yellow get updates. Then the campaign will start to download.

Well I reinstalled the game and that fixed it, I’m now installing the campaign. Kind of ridiculous you had to open up the MS store and update from there though. What’s even the point of having an Xbox app on PC if it makes you use the MS store?

1 Like

I ran into the same issue. I preinstalled the campaign and went through “manage game” and selected add campaign but then it tried to download the campaign a second time. I uninstalled the game and now in the process of the slow Xbox App download speed.

Not sure I’ve had no issues. Maybe try uninstall and reinstall?

The uninstall and reinstall worked for me also, probably not ideal. This is the Xbox App…

what a pan this is and well if they wanted a Review BOMB they sure got it as is now a 2 star rating in teh Xbox App

I don’t even have the game installed and I can’t download it. Wtf is the problem?