Brute Force Acheivement (XBOX ONE) glitched!

Hi there,

I’m facing an issue with the Brute Force Achievement which is quite interesting. When looking at the Achievements on the dashboard it shows as the progress being 100% but will not unlock. I’ve tried to delete my profile and re-download it, unplug all cords and hold the xbox button to clear the cache, re-installing the game. Don’t know what else to do to get this to get unstuck.

Is there a way to reset this achievement to 0% so that I can do it again to unlock it?

If it’s a current bug, please let me know if it is being worked on; otherwise, any help to solve this would be great.

I hate the fact that all save files are on the cloud so that I can’t even delete my save file to solve these problems myself!


Have you tried re-attempting the level yet? Make sure to use all/only of the required attacks: Brute Shot, Melee, and Grenades.

Yes I have done this about 10 times. Like I said, the achievement shows as 100% done but not unlocking.

Someone is having a similar issue with Weapon of Choice. I am quoting this post from the Spartan Assault forum. Seems like it could be an OS level issue since the game is correctly telling the OS that 100% progress has been made, yet the OS doesn’t unlock the achievement.

> My xbone’s achievement says i have 100% and the progress bar is full but the achievement does not want to unlock. I have used all the weapons several times to get kills and nothing. I have gotten kills with the weapons all from picking them up and as well from load outs. I also made sure to finish my missions in hopes that the progress would pop the achievement. Anybody else who has this issue or has a solution it would be much appreciated.

Fair enough Mathguy. Do you know if there is a solution on how to fix this? I went ahead and called XBOX Support and they were useless as they mentioned to contact 343.

Sorry, I haven’t heard of any solutions. If I hear of one, I’ll certainly let you know. I hope that if the community gives them enough data, 343i or MS can fix these issues. I’m personally affected by the Extra Credit issue.

Needed to double-check as if you’d done it on another version of the game, it can also say 100% done without unlocking the achievement because it hadn’t been done on the X1. We’ll pass this info along.

I can see that marklynx unlocked Brute Force on Win 8 on Jan 7. But I don’t know if he tried on X1 first. Since Brute Force does not carry over from WP8 to Win 8 (or vice versa) and isn’t related to a stat, I doubt that playing the Win 8 version has any effect on Brute Force for X1.

War Psyco has not played SA on any other platform, according to his achievement lists.

I completed SA on WP8 and Win 8, then had no trouble with X1, except for the now well-known Extra Credit issue.

I actually had it tried on the X1 first. Tried it about 5 times there before going to the dashboard to see if it had silently popped. This is where I saw that the thing had glitched on me.

Then I said maybe I don’t know what I’m doing and let me try it on Win8. First try got it there. So it’s not me, it’s either X1 or Halo in this case.

I went ahead and tried it several more times even called xbox support, deleted my cache, my profile, the game, etc… Nothing helped.

This is a platform issue, not a game issue. We reached out to Xbox Live Support and they are aware of this problem and are working on a fix. For additional information, you can reach out to them directly.