Broken lock-on mechanics for rockets?

I was playing a custom game against a friend, and he got in a banshee. I grabbed a rocket launcher, waited for the little diamond reticle to appear, and then fired. The rocket went straight. So I fired the second rocket and it worked.

I also tried this with the rocket hog turret, and it doesnt lock on either, despite the little diamond reticle showing up. Is this some sort of glitch or broken mechanic? It would also be nice if it had a little sound indicator like it did from halos 2-reach. I noticed that the dominion turrets make a sound for lock-ons, but neither the rocket launcher nor the rocket hog turret does.

Thoughts?

The Diamond has to turn red before you shoot.

You have to wait for the diamond to start flashing before you fire, but as you said it can be really hard to judge when because there’s no audio indicator like in past Halo’s.

It’s a bit weird in this game since you have to wait for the diamond to flash but it’s pretty hard to see sometimes.