Anti Cheat Error

Hey guys I keep getting an anti cheat error on PC and not sure how to fix this. I can play a few games then get the below error midgame and forces me back to the main menu. This has cause me to be banned a couple times now. Anyone know a fix?

Anti-Cheat Incident 

You cannot access this feature due to the following anti-cheat issue: Unknown file version (mcc\binaries\win64\mccwinstore-win64-shipping.exe)
2 Likes

If you have the Windows store version, then:

Windows 10:
Go to Settings, then Apps
Click the Halo MCC app, then select ‘Advanced options’
Click ‘Repair’

Windows 11:
Go to Settings, then Apps
Select 'Apps & features
Scroll down the the Halo MCC app. To the right of the file size, click the three vertical dots and select ‘Advanced options’
Click ‘Terminate’ (probably not necessary, but do it anyway)
Click ‘Repair’.

2 Likes

How is it we get a better possibly solution here rather than from submitting a ticket?

1 Like

Can confirm this doesn’t work.

OK if you have the Steam Version do this:

  1. Goto Steam
  2. List your games
  3. Right Click On MCC/properties
  4. Click on verify files.

That’s it. Hope That Works :fist_right: :fist_left:

It worked for me (Windows 11). If repair doesn’t work, reset is worth a try (the game will resync your data when you next start it). If that doesn’t work, then I guess it’s uninstall/reinstall.

None of this seems to work for me. I have had this problem on Windows 10, tried every single thing possible, resetting the game, repairing it, uninstalling and reinstalling multiple times, I even downloaded Windows 11 and tried to do those new methods and still nothing, I have done everything on windows 10, on windows 11 and it still spams me those errors for that same exact file, the “(mcc\binaries\win64\mccwinstore-win64-shipping.exe)”.

Does anyone have any advice or something to do with this. It is so depressing and sad this game has so many issues on PC, i’ve never had this issue in the entire 2 years i have had this PC, 343 please fix it or does someone with more knowledge than me give me some advice? It would be much appreciated.

Thanks so much guys, love live Halo

Same thing for me, can’t even play MCC for a long period because of this. I regret having MCC on microsoft store. Apparently, Steam version is less worst.

1 Like

I’m experiencing the same issue. I was in a 4v4 match where 3/8 players got kicked due to this issue. (I was in a party so the other users playing in the console told me what happened).

This issue is presented since 5/11 update and it’s affecting PC users at random moments. One day I ended up getting banned for 3 hours.

I already did a clean installation but nothing.

1 Like

This is definitely happening on Steam too.

Appears to continue to be unstable. Most annoying aspect is the lack of information the error gives you, so you have zero idea what happened.

1 Like

I have that exact issue Warning : mcc\binaries\win64\mccwinstore-win64-shipping.exe

It started 3 days ago, my game crashes between 3-4 games and i need to restart the game.

I don´t want to reinstall the hole MCC game, its very big. Any solution would be appreciated. Thanks

steam or ms store?

The above mentioned solutions did not fix my issue. It seems uninstalling and reinstalling was the only fix for me which is very unfortunate considered the sheer size of the MCC.

1 Like

Both. And doing a clean installation won’t fix the issue. I think there’s something wrong since they updated the launcher for Halo MCC PC.

I am having the same issue /w MS store version. Just started happening since the last update. I tried resetting the game files with no luck.

Same issue here. Problems with the mcc\binaries\win64\mccwinstore-win64-shipping.exe. XBox PC App Version. Reseting the app doesn’t solve the problem. This is very frustrating :frowning:

1 Like

still happening. on pc. playing mcc on gamepass thru xbox app.

fix your game, 343i.

If you are having this issue then your best option is to re-install the entire MCC. Steam users can navigate to the file in question, move it out of the game files into an unrelated folder on the desktop or wherever, and then verify the game files in order to get a new copy. Windows Store users (Xbox Game Pass gets you the Windows Store version) cannot do that partly because the Windows Store version is a locked down .UWP file. I’m surprised to hear that inside of it is an .exe file; that changes my perspective on what .UWP files are.

The best way to figure out what has gone wrong in MCC is to identify the symptoms. Exactly what goes wrong and exactly when it does can sometimes provide clues that imply what is busted. In some cases that’s fixable on your own. The Steam version has these kinds of problems happen too.

Click HERE for info about how to backup saved forge maps and gametypes before uninstalling.

If you have saved gametypes and forge maps be careful about uninstalling because that can sometimes remove them. You can find them saved here, if you’ve saved any, sorted first by game and then by type.

C:\Users\<USER>\AppData\LocalLow\MCC\LocalFiles
%userprofile%\AppData\LocalLow\MCC\LocalFiles

Don’t mix up which Halo game these are for. “.bin” files are gametypes and “.mvar” files are forge maps. They have hexadecimal names but you can (most of the time) see the in-game name and description if you open these files up in Notepad, enable Word Wrap, and then look near the top of the document. Do NOT edit the contents of the file using Notepad. It will corrupt the file and MCC may give an error on startup because it doesn’t know what to do with broken files. You can safely rename the file though. Be aware that doing that will mean the next time you edit it you will have to use Save As instead of just Save.

.

Click HERE for an idea of how to fix it without reinstalling.

The steps that I am explaining in the next paragraph work very well for the Steam version. I don’t know how the Windows Store is different but the file structure inside of the .UWP file appears to be identical to the Steam version. My hope is that by removing the file that Easy Anti-Cheat (EAC) is flagging and then using the “repair” feature as outlined by LgndryDad that you will get a new copy of this file. (That is partly how Steam’s “verify game files” feature works.) I strongly recommend moving the file out instead of deleting it so you always have a working copy if you want to undo something.

It sounds like there’s a blue Easy Anti-Cheat (EAC) error. Apparently it’s citing a specific file. I recommend: (1) navigating to that specific file, (2) opening up a second folder on the desktop or anywhere on your PC that is not inside of the game files, and then (3) moving (not copying or deleting) it out. (4) For Steam users the next step is to verify the game files to get a new copy of this file. For Windows Store users I recommend trying the “Repair” method that LgndryDad wrote out above. (5) After that process is done, refresh the File Explorer window and check to see if you have a new copy of the file that you moved out. (6) If you do then try starting the game again to see if that fixed the problem. Be aware that if there were multiple problems the game might now be warning you of the other problem. So don’t be alarmed if there’s a different error message.

You’ll run into a problem doing this very fast. Microsoft’s proprietary UWP file format is locked down, so you’ll have to break into files on your own computer. This has already been done by people who want to mod the game with the same freedom that the Steam version users have. I’m not familiar with this process but this link seems like a good place to start reading. It’s old but most of it’s still valid. I know nothing about the third-party tools.

https://www.reddit.com/r/halomods/comments/e5tsmu/dumping_the_ms_store_version_of_halo_mcc/

I found a new lead! If this happens after a reinstall then read the post I’m linking to. The top part is in French but it’s repeated in English. It’s about someone who fixed this issue by changing how their hard drive was saving files. “Windows compression must be disabled on the hard drive where Halo is installed.”

https://steamcommunity.com/app/976730/discussions/0/3391786047382857959/

Same issue here, and I get a temp ban each time as if I’ve done something wrong.

I’ve done everything short of reinstall, including checking the install drive compression (which is and has always been disabled for mine). Reinstall is a nonstarter of a “solution.”

343, fix this bug please.

1 Like