15GB Patch "Installation Stopped"

So i keep getting this error when i try to install the patch? here are the steps I’ve done so far which were suggested to me by Xbox support.

1.Cleared Persistent storage 5 times (done this a total of about 20 time all up)

  1. Cleared Alternate Mac address (multiple times) then restarted Xbox.

  2. Checked network settings (multiple times) Everything is fine with my Net.

  3. Done a FULL FACTORY DEFAULT RESTORE of my Xbox, still no luck.

  4. Tried installing another game and then updating it, worked perfectly.

  5. I’ve tried installing the game via disc offline then going online to install the update, that didn’t work.

  6. I’ve tried installing the game while online and that didn’t work either.

  7. I’ve power cycled my Xbox 4-5 times throughout these processes.

If anyone knows any other way to fix this “Installation Stopped !” error when downloading the 15 GB patch then please help me. I’m desperate :frowning:

EDIT: after going through all these steps with MS support they suggested that it was a problem with the servers at 343. Seems strange because I haven’t heard anyone else talk about problems installing.


it is on their end mate, my install and download took around 28 hours lol…